1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Computer turns off in sleep mode

Discussion in 'Bits & Bytes' started by dsl987, Aug 30, 2015.

  1. dsl987

    dsl987 Member

    My very reliable home computer has just developed a habit of turning itself off while in sleep mode. It used to sleep with no problems, and I much prefer this to shutting down because it fires up right away. Anyone got any ideas what might be causing this? The only thing I have changed recently was to add the SSD as my primary drive and use the old HD as secondary storage.
    I guess I'm a bit worried that this shutting down is a sign that this computer's time might be done. While not necessarily a bad thing, in that I get to upgrade, but it's just such a PITA to get everything back the way I want it.

    Thoughts?
     
  2. Andy

    Andy ΜΟΛΩΝ ΛΑΒΕ

    Look at the power management settings for the SSD drive, if it is set to allow it to shut itself off to save power, being it's the primary drive it might be causing the PC to not wake up correctly.
     
  3. dsl987

    dsl987 Member

    I don't think it's a case of not waking up correctly, it's more that the computer completely shuts down, but not in a controlled way. There's no activity when pressing keys and I have to push the power button to get it running again, when it boots it tells me Windows did not shut down properly.

    I did look at the settings and have turned off HD sleep. Will see how that goes.
     
  4. Biker

    Biker Administrator Staff Member

    It almost sounds as if you're losing power. Hook up a clock to the same outlet and see if it's flashing when your computer acts up.
     
  5. eakes

    eakes Registered User

    If not the AC, the computer PS could be slowly going away.
     
  6. dsl987

    dsl987 Member

    Just happened again, came home during lunch and tapped the keyboard with no response. I'm tempted to think Eakes might be right, and it could be the power supply dying. Trying to think if I have any alarm clocks in the house that still plug in .
     
  7. Andy

    Andy ΜΟΛΩΝ ΛΑΒΕ

    If it were a power issue, turning off sleep mode And leave it on for a day would result in a powered off PC when you returned.
     
  8. dsl987

    dsl987 Member

    Good point Andy, I'll set it to always on for a while and see what happens
     
  9. Andy

    Andy ΜΟΛΩΝ ΛΑΒΕ

    One other thing to take a look at, open up the event viewer (control panel > admin tools > Event Viewer) and check out the OS system and application logs there for any errors that would point out faulty hardware or app/OS crashing.

    You'd be surprised how many cases I close at work by showing system admins who claim to be in the biz for years and never look here before they call up and blame the software I support only to find they have a drive (or 3) going south.
     
  10. Greg

    Greg Full Member

    Biggest question: Did it start happening when you added the SSD or did some time pass after that before it appeared?

    I don't see you mentioned your OS. Hope it's one with a policy manager for power. (My Win7HP got ripped of all the good stuff.) If you got it, read the power policy settings very carefully.

    And as mentioned, the event log. You may have to enable event logging for the events you want.
     
  11. dsl987

    dsl987 Member

    Will take a look. Thanks
     
  12. Greg

    Greg Full Member

    If you run out of leads I'll share my secret resource. Home of Gibson Research Corporation Join their news server and ask your question in grc.techtalk

    Beware, there be geeks there. You might even be the only non-geek.
     
  13. Brazbit

    Brazbit Nah... It can't be.

    Perhaps it is sleeping fine and then trying to go into hibernate and it is failin g when attempting to write to the SSD for some reason. If Hibernate is on, disable it. Many systems will sleep in the traditional mode and then "Deep Sleep" (Hibernate) after a set amount of time to save power. Some newer systems even have a dedicated Deep Sleep state other than hibernate and that can be disabled in Bios/EFI for a reason.



    I usually suggest folks choose between sleep or hibernate and disable the other one. Having both has always caused strange issaues such as the one described even after 20 years of operating systerms trying to get it right.
     
  14. dsl987

    dsl987 Member

    Well it turned out to be the power supply, finally got around to replacing it this weekend.
    Thanks for all the help
     

Share This Page